You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/farstream/files/farstream-0.2.8-make43.patch

61 lines
1.9 KiB

--- a/farstream/Makefile.in
+++ b/farstream/Makefile.in
@@ -17,6 +17,8 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
@@ -549,7 +551,7 @@
glib_enum_define = FS
glib_gen_prefix = _fs
glib_gen_basename = fs
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
@HAVE_INTROSPECTION_TRUE@introspection_sources = \
@HAVE_INTROSPECTION_TRUE@ $(libfarstream_@FS_APIVERSION@_la_SOURCES) \
@HAVE_INTROSPECTION_TRUE@ $(nodist_libfarstreaminclude_HEADERS) \
--- a/gst/fsrtpconference/Makefile.in
+++ b/gst/fsrtpconference/Makefile.in
@@ -17,6 +17,8 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
@@ -569,7 +571,7 @@
glib_enum_define = FS_RTP
glib_gen_prefix = _fs_rtp
glib_gen_basename = fs-rtp
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
all: all-am
.SUFFIXES:
--- a/transmitters/rawudp/Makefile.in
+++ b/transmitters/rawudp/Makefile.in
@@ -17,6 +17,8 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
@@ -496,7 +498,7 @@
glib_enum_define = FS_RAWUDP
glib_gen_prefix = _fs_rawudp
glib_gen_basename = fs-rawudp
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
all: all-am
.SUFFIXES: