You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/unison/files/unison-2.48.4-Makefile-dep....

21 lines
542 B

Makefile.OCaml: fswatch.cmi depends on ubase/prefs.cmi.
The dependency is needed to compile unison
in parallel.
Reference: https://github.com/bcpierce00/unison/pull/100
diff --git a/Makefile.OCaml b/Makefile.OCaml
index 21610ce..84fe7ad 100644
--- a/Makefile.OCaml
+++ b/Makefile.OCaml
@@ -426,6 +426,8 @@ win32rc/unison.res.lib: win32rc/unison.res
@echo "$(CAMLC): $< ---> $@"
$(CAMLC) $(CAMLFLAGS) -c $(CWD)/$<
+fswatch.cmi : ubase/prefs.cmi
+
%.cmo: %.ml
@echo "$(OCAMLC): $< ---> $@"
$(OCAMLC) $(CAMLFLAGS) -c $(CWD)/$<