You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-devel/bc/files/bc-1.07.1-use-system-bc.patch

17 lines
556 B

when cross-compiling, the local fbc binary won't work. use the system
bc instead as the demands of the .b script are simple enough.
https://bugs.gentoo.org/627126
--- a/bc/Makefile.in
+++ b/bc/Makefile.in
@@ -628,7 +628,7 @@ libmath.h: libmath.b $(fbcOBJ) $(LIBBC)
echo '{0}' > libmath.h
$(MAKE) global.o
$(LINK) -o fbc $(fbcOBJ) global.o $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
- ./fbc -c $(srcdir)/libmath.b </dev/null >libmath.h
+ bc -c $(srcdir)/libmath.b </dev/null >libmath.h
$(srcdir)/fix-libmath_h
rm -f ./fbc ./global.o
sbc.o: sbc.c