You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/sparky/files/3.115-makefile.patch

18 lines
580 B

diff --git a/Makefile b/Makefile
index bb27034..30979bd 100644
--- a/Makefile
+++ b/Makefile
@@ -48,6 +48,12 @@ TKINTER_PYMOD = _tkinter$(PYMOD_SUFFIX)
all nopython $(SPY_PYMOD) $(TKINTER_PYMOD) $(EXECUTABLES) debug-sparky clean: force
cd $(SPARKY_OBJ) && $(MAKE) -f $(SPARKY_SRC)/Makefile -e $@
+libraries:
+ cd $(SPARKY_OBJ) && $(MAKE) -f $(SPARKY_SRC)/Makefile -e $(SPY_PYMOD) $(TKINTER_PYMOD)
+
+binaries:
+ cd $(SPARKY_OBJ) && $(MAKE) -f $(SPARKY_SRC)/Makefile -e $(EXECUTABLES) debug-sparky
+
Makefile.dep TAGS: force
cd $(SPARKY_SRC) && $(MAKE) -f Makefile -e $@