You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/docutils/files/docutils-0.6-extra_modules....

25 lines
828 B

--- setup.py
+++ setup.py
@@ -182,19 +182,8 @@
List of (module name, minimum __version__ string, [attribute names])."""
def get_extras():
- extras = []
- for module_name, version, attributes in extra_modules:
- try:
- module = __import__(module_name)
- if version and module.__version__ < version:
- raise ValueError
- for attribute in attributes or []:
- getattr(module, attribute)
- print ('"%s" module already present; ignoring extras/%s.py.'
- % (module_name, module_name))
- except (ImportError, AttributeError, ValueError):
- extras.append(module_name)
- return extras
+ # Old method does not work for upgrading/downgrading docutils.
+ return ["roman"]
if __name__ == '__main__' :