You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/graphviz/files/graphviz-2.26.3-libtool.patch

28 lines
557 B

http://bugs.gentoo.org/339298
--- lib/gvc/gvcext.h
+++ lib/gvc/gvcext.h
@@ -80,9 +80,11 @@
#if defined(GVDLL)
__declspec(dllexport) lt_symlist_t lt_preloaded_symbols[];
#else
+#if !defined(LTDL_H)
extern lt_symlist_t lt_preloaded_symbols[];
#endif
#endif
+#endif
#ifdef __cplusplus
--- lib/gvc/Makefile.am
+++ lib/gvc/Makefile.am
@@ -18,7 +18,7 @@
-I$(top_srcdir)/lib/pathplan \
-I$(top_srcdir)/lib/$(GRAPH) \
-I$(top_srcdir)/lib/cdt \
- $(INCLTDL) -I$(top_srcdir)/libltdl \
+ $(INCLTDL) \
-DGVLIBDIR=\"$(pkglibdir)\"
if WITH_WIN32