You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_makefile...

68 lines
2.2 KiB

Joerg Bornkessel <hd_brummy@g.o> 22 Okt 2009
Matthias Schwarzott <zzam@g.o> 23 Okt 2009
diff -Naur graphtft-24.orig/Makefile graphtft-24/Makefile
--- graphtft-24.orig/Makefile 2009-10-21 21:53:56.000000000 +0200
+++ graphtft-24/Makefile 2009-10-21 21:57:24.000000000 +0200
@@ -158,10 +158,10 @@
DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
ifdef HAVE_IMLIB
- LIBS += `imlib2-config --libs`
+ LIBS += $(shell imlib2-config --libs)
ifdef HAVE_IMAGE_MAGICK
- LIBS += `Magick++-config --libs`
+ LIBS += $(shell Magick++-config --libs)
DEFINES += -DHAVE_IMAGE_MAGICK
endif
@@ -170,8 +170,8 @@
endif
ifdef HAVE_GTOP
- GTOP_INC = `pkg-config libgtop-2.0 --cflags`
- GTOP_LIB = `pkg-config libgtop-2.0 --libs`
+ GTOP_INC = $(shell pkg-config libgtop-2.0 --cflags)
+ GTOP_LIB = $(shell pkg-config libgtop-2.0 --libs)
DEFINES += -DWITH_SYSINFO
LIBS += $(GTOP_LIB)
@@ -186,8 +186,8 @@
endif
ifdef HAVE_DFB
- INCLUDES += `directfb-config --cflags`
- LIBS += `directfb-config --libs`
+ INCLUDES += $(shell directfb-config --cflags)
+ LIBS += $(shell directfb-config --libs)
DEFINES += -DHAVE_DFB
endif
diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-22 17:39:55.000000000 +0200
+++ graphtft-24/graphtft-fe/Makefile 2009-10-22 17:41:29.000000000 +0200
@@ -1,9 +1,9 @@
CXX = g++
CXXFLAGS = -pipe -ggdb -O2 -Wall -W -D_REENTRANT -fPIC
-INCPATH = -I. `Magick++-config --cppflags`
+INCPATH = -I. $(shell Magick++-config --cppflags)
LFLAGS = -Wl,--no-undefined
-LIBS = -lpthread `imlib2-config --libs` `Magick++-config --libs`
+LIBS = -lpthread $(shell imlib2-config --libs) $(shell Magick++-config --libs)
AR = ar
TARGET = graphtft-fe
diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-23 16:20:43.000000000 +0200
+++ graphtft-24/graphtft-fe/Makefile 2009-10-23 16:21:20.000000000 +0200
@@ -17,7 +17,7 @@
all:
echo Build graphTFT Frontend
- @(make $(TARGET))
+ @$(MAKE) $(TARGET)
$(TARGET): $(OBJECTS)