You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/nfdump/files/nfdump-1.6.14-libft.patch

15 lines
709 B

--- a/configure.ac
+++ b/configure.ac
@@ -125,9 +125,8 @@
if test ! -f "$WHERE_FTPATH/include/ftlib.h"; then
AC_MSG_ERROR(ftlib.h file not found in flow-tools directory '$WHERE_FTPATH'. Use --with-ftpath=PATH)
fi
- if test ! -f "$WHERE_FTPATH/lib/libft.a" -a -f "$WHERE_FTPATH/lib64/libft.a" ! -f "$WHERE_FTPATH/lib/libft.so" -a -f "$WHERE_FTPATH/lib64/libft.so"; then
- AC_MSG_ERROR(libft.a not found in flow-tools directory '$WHERE_FTPATH'. Build flow tools first)
- fi
+ AC_CHECK_LIB([ft], [main],,
+ AC_MSG_ERROR(libft not found in flow-tools directory '$WHERE_FTPATH'. Build flow tools first))
FT_INCLUDES="-I$WHERE_FTPATH/include -I$WHERE_FTPATH/lib"
FT_LDFLAGS="-L$WHERE_FTPATH/lib"
else