You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/postal/files/02_postal-0.72-nossl.patch

73 lines
1.9 KiB

diff -NrU5 postal-0.69.orig/configure.in postal-0.69/configure.in
--- configure.in 2008-04-09 03:08:28.000000000 +0200
+++ configure.in 2008-04-23 22:37:41.000000000 +0200
@@ -13,15 +13,28 @@
else
stripping="-s"
fi
AC_ARG_ENABLE(openssl,
- [ --disable-openssl disables openssl support],
- DISABLEOPENSSL=$opensslval, DISABLEOPENSSL=no)
+ [ --disable-openssl disable openssl support],
+ [ if test $enableval = yes; then
+ DISABLEOPENSSL=no
+ else
+ DISABLEOPENSSL=yes
+ fi ]
+ ,
+ [ DISABLEOPENSSL=no ])
+
AC_ARG_ENABLE(gnutls,
- [ --disable-gnutls disables gnutls support],
- DISABLEGNUTLS=$gnutlsval, DISABLEGNUTLS=no)
+ [ --disable-gnutls disables gnutls support],
+ [if test $enableval = yes; then
+ DISABLEGNUTLS=no
+ else
+ DISABLEGNUTLS=yes
+ fi]
+ ,
+ [ DISABLEGNUTLS=no ])
dnl Checks for programs.
AC_LANG_CPLUSPLUS
AC_PROG_CC
AC_PROG_CXX
@@ -118,17 +131,17 @@
crypt_ldflags=
if [[ "$GNUTLS" = "no" ]]; then
gnutls=""
else
gnutls="#define USE_GNUTLS"
- crypt_ldflags="$extra_ldflags -lgnutls -lgcrypt"
+ crypt_ldflags=" -lgnutls -lgcrypt"
fi
if [[ "$OPENSSL" = "no" ]]; then
openssl=""
else
openssl="#define USE_OPENSSL"
- crypt_ldflags="$extra_ldflags -lssl -lcrypto"
+ crypt_ldflags=" -lssl -lcrypto"
fi
AC_SUBST(large_file)
large_file=""
diff -NrU5 postal-0.69.orig/Makefile.in postal-0.69/Makefile.in
--- Makefile.in 2008-04-10 03:19:34.000000000 +0200
+++ Makefile.in 2008-04-23 22:37:13.000000000 +0200
@@ -16,11 +16,11 @@
INSTALL=@INSTALL@
TESTEXE=ex-test
BASEOBJS=userlist.o thread.o results.o address.o tcp.o cmd5.o mutex.o logit.o expand.o @extra_objs@
LFLAGS=-lstdc++ @extra_ldflags@
-CRYPTLFLAGS=-lstdc++ @crypt_ldflags@
+CRYPTLFLAGS=-lstdc++ @extra_ldflags@ @crypt_ldflags@
ALLOBJS=$(BASEOBJS) smtp.o client.o basictcp.o bhmusers.o smtpserver.o
postal: postal.cpp $(BASEOBJS) postal.h smtp.o