You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/siphon/files/siphon-666-gentoo.patch

20 lines
441 B

--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
CC = gcc
CCFLAGS = -Wall -pthread -ggdb
-CFLAGS = -Wall -O2 -pthread -ggdb -I.
+CFLAGS += -pthread -Wall -I.
LIBS = -lpcap
OBJS = parse.o sniff.o main.o log.o
SRCS = ${OBJS:.o=.c}
@@ -9,7 +9,7 @@
all: $(TARGET)
$(TARGET): $(OBJS)
- $(CC) $(CCFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+ $(CC) $(CCFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
clean:
rm -f $(OBJS) *~ *.core core siphon