You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/wireshark/files/wireshark-99999999-pkgconfi...

63 lines
1.5 KiB

--- a/configure.ac
+++ b/configure.ac
@@ -242,7 +242,7 @@
# This is referenced via AC_REQUIRE([PKG_PROG_PKG_CONFIG] in some macros
# like PKG_CHECK_MODULES. If the first call to such a macro is under an
# "if" statement, it's safer to call PKG_PROG_PKG_CONFIG directly, see
-# the comments in acolocal.m4
+# the comments in aclocal.m4
#
# We want version 0.7 or better. (XXX - explain why. Is that just
# because our Qt tests were originally based on AM_PATH_GTK, and *it*
@@ -1910,6 +1910,19 @@
AC_SUBST(plugins_dir)
#
+# Find out where to store wireshark.pc and what should be in it
+#
+
+PKG_INSTALLDIR
+
+AC_SUBST(CMAKE_INSTALL_PREFIX,[$prefix])
+AC_SUBST(CMAKE_INSTALL_LIBDIR,[`basename $libdir`])
+PLUGIN_INSTALL_DIR="\${libdir}/$PACKAGE_NAME/$PACKAGE_VERSION/$plugins_dir"
+AC_SUBST(PLUGIN_INSTALL_DIR)
+PROJECT_VERSION="$PACKAGE_VERSION"
+AC_SUBST(PROJECT_VERSION)
+
+#
# If we have <dlfcn.h>, check whether we have dladdr.
#
if test "$ac_cv_header_dlfcn_h" = "yes"
@@ -3080,10 +3093,15 @@
sinclude(asn1/Custom.m4) dnl
ifdef(_CUSTOM_ASN1_AC_OUTPUT_,, define(_CUSTOM_ASN1_AC_OUTPUT_, )) dnl
+#
+# Configuration output
+#
+
AC_CONFIG_HEADERS(config.h)
AC_OUTPUT(
Makefile
doxygen.cfg
+ wireshark.pc
asn1/Makefile
_CUSTOM_ASN1_AC_OUTPUT_
asn1/acp133/Makefile
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,6 +56,12 @@
smi_modules ipmap.html pdml2html.xsl
#
+# Install a pkgconfig file
+#
+
+pkgconfig_DATA = wireshark.pc
+
+#
# Install global profiles in the "profiles" subdirectory
#
profilesdir = $(pkgdatadir)