You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libcerf/files/libcerf-1.3-autotools.patch

71 lines
2.7 KiB

Send upstream (j.wuttke@fz-juelich.de) 14.07.14
diff -Naur libcerf-1.3.orig/configure.ac libcerf-1.3/configure.ac
--- libcerf-1.3.orig/configure.ac 2013-07-17 03:49:33.000000000 -0600
+++ libcerf-1.3/configure.ac 2014-07-21 17:01:15.399324021 -0600
@@ -19,7 +19,7 @@
# Website:
# http://apps.jcns.fz-juelich.de/libcerf
-AC_INIT([cerf],[1:3],[http://apps.jcns.fz-juelich.de/libcerf])
+AC_INIT([libcerf],[1:3],[http://apps.jcns.fz-juelich.de/libcerf])
# version is current:revision:age; for simplicity, we always put age=0
# <- http://www.sourceware.org/autobook/autobook/autobook_91.html
@@ -31,7 +31,7 @@
LT_INIT([disable-static])
AC_PROG_CC_C99
-AC_SUBST(AM_CFLAGS,"-pedantic -Wall -Werror")
+AC_SUBST(AM_CFLAGS,"-pedantic -Wall")
AC_CONFIG_HEADERS([config.h]) # to avoid endless -D options
AC_HEADER_STDC
diff -Naur libcerf-1.3.orig/libcerf.pc.in libcerf-1.3/libcerf.pc.in
--- libcerf-1.3.orig/libcerf.pc.in 2013-07-17 03:51:59.000000000 -0600
+++ libcerf-1.3/libcerf.pc.in 2014-07-14 11:18:01.646512503 -0600
@@ -7,4 +7,5 @@
Description: Complex error function library
Version: @PACKAGE_VERSION@
Libs: -L${libdir} -lcerf
+Libs.private: -lm
Cflags: -I${includedir}
diff -Naur libcerf-1.3.orig/man/Makefile.am libcerf-1.3/man/Makefile.am
--- libcerf-1.3.orig/man/Makefile.am 2013-02-01 02:00:14.000000000 -0700
+++ libcerf-1.3/man/Makefile.am 2014-07-14 11:17:36.266182267 -0600
@@ -19,9 +19,8 @@
# Website:
# http://apps.jcns.fz-juelich.de/libcerf
-man_MANS = w_of_z.3 im_w_of_x.3 dawson.3 cdawson.3 cerf.3 cerfc.3 erfcx.3 cerfcx.3 erfi.3 cerfi.3 voigt.3
-auxdir = $(datadir)/man/html
-aux_DATA = w_of_z.html voigt.html dawson.html cerf.html erfcx.html erfi.html
+man_MANS = w_of_z.3 im_w_of_x.3 dawson.3 cdawson.3 libcerf-cerf.3 cerfc.3 erfcx.3 cerfcx.3 erfi.3 cerfi.3 voigt.3
+html_DATA = w_of_z.html voigt.html dawson.html cerf.html erfcx.html erfi.html
w_of_z.3 : w_of_z.pod
pod2man -s 3 -c "libcerf manual" $< > $@
@@ -35,7 +34,7 @@
cdawson.3 : dawson.pod
pod2man -s 3 -c "libcerf manual" $< > $@
-cerf.3 : cerf.pod
+libcerf-cerf.3 : cerf.pod
pod2man -s 3 -c "libcerf manual" $< > $@
cerfc.3 : cerf.pod
diff -Naur libcerf-1.3.orig/test/Makefile.am libcerf-1.3/test/Makefile.am
--- libcerf-1.3.orig/test/Makefile.am 2013-07-17 01:45:37.000000000 -0600
+++ libcerf-1.3/test/Makefile.am 2014-07-14 11:16:00.204932368 -0600
@@ -20,8 +20,10 @@
# http://apps.jcns.fz-juelich.de/libcerf
AM_CFLAGS += -I$(srcdir)/../lib
-noinst_PROGRAMS = test_libcerf_1 runvoigt run_w_of_z
+noinst_PROGRAMS = runvoigt run_w_of_z
test_libcerf_1_SOURCES = test1.c
runvoigt_SOURCES = runvoigt.c
run_w_of_z_SOURCES = run_w_of_z.c
AM_LDFLAGS = -lm -L../lib -lcerf
+check_PROGRAMS = test_libcerf_1
+TESTS = test_libcerf_1