You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch

22 lines
505 B

--- a/dmtcp/src/Makefile.am
+++ b/dmtcp/src/Makefile.am
@@ -66,7 +66,7 @@
dmtcp_inspector_SOURCES = dmtcp_inspector.cpp
-dmtcphijack_so_LDFLAGS = -shared -avoid-version -module
+dmtcphijack_so_LDFLAGS = -shared -module
#dmtcp_nocheckpoint_LDFLAGS = -static
--- a/dmtcp/src/dmtcpalloc.h
+++ b/dmtcp/src/dmtcpalloc.h
@@ -33,6 +33,7 @@
#include <iostream>
#include <sstream>
#include <fstream>
+#include <cstddef>
#define DMTCPSTRING dmtcp::string
#define DMTCPVECTOR(T) dmtcp::vector<T>