You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-libs/gtk+/files/gtk+-2.24.27-update-icon-ca...

65 lines
1.9 KiB

From 2537d97e4685767ce22834c0dd24d37ba715fb52 Mon Sep 17 00:00:00 2001
From: Gilles Dartiguelongue <eva@gentoo.org>
Date: Sat, 9 May 2015 23:30:58 +0200
Subject: [PATCH] Always use external gtk-update-icon-cache
---
configure.ac | 8 +++-----
gtk/Makefile.am | 13 ++-----------
2 files changed, 5 insertions(+), 16 deletions(-)
diff --git a/configure.ac b/configure.ac
index 2671a3d..fa46004 100644
--- a/configure.ac
+++ b/configure.ac
@@ -913,11 +913,9 @@ dnl Look for a host system's gdk-pixbuf-csource if we are cross-compiling
AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
-if test $cross_compiling = yes; then
- AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
- if test x$GTK_UPDATE_ICON_CACHE = xno; then
- REBUILD_PNGS=#
- fi
+AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
+if test x$GTK_UPDATE_ICON_CACHE = xno; then
+ REBUILD_PNGS=#
fi
AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource, no)
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 248220d..42e4c23 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1039,8 +1039,7 @@ endif
# Installed tools
#
bin_PROGRAMS = \
- gtk-query-immodules-2.0 \
- gtk-update-icon-cache
+ gtk-query-immodules-2.0
bin_SCRIPTS = gtk-builder-convert
@@ -1390,16 +1389,8 @@ stamp-icons: $(STOCK_ICONS)
) done \
&& touch stamp-icons
-if CROSS_COMPILING
-gtk_update_icon_cache_program = $(GTK_UPDATE_ICON_CACHE)
-else
-gtk_update_icon_cache_program = \
- ./gtk-update-icon-cache
-endif
-
gtkbuiltincache.h: @REBUILD@ stamp-icons
- $(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT)
- $(gtk_update_icon_cache_program) --force --ignore-theme-index \
+ $(GTK_UPDATE_ICON_CACHE) --force --ignore-theme-index \
--include-image-data \
--source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
mv gtkbuiltincache.h.tmp gtkbuiltincache.h
--
2.3.6