You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-link...

62 lines
2.0 KiB

Makefile | 4 ++--
libhosts_gatherer/Makefile | 2 +-
libnessus/Makefile | 4 ++--
libnessus/kb.c | 1 +
4 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/Makefile b/Makefile
index 938d1b2..672d8cf 100644
--- a/Makefile
+++ b/Makefile
@@ -3,8 +3,8 @@ include nessus.tmpl
ALLDEPS = nessus.tmpl nessus-config
all: $(ALLDEPS) $(PCAP_MAKE)
- cd libnessus && ${MAKE}
- cd libhosts_gatherer && ${MAKE}
+ ${MAKE} -C libnessus
+ ${MAKE} -C libhosts_gatherer
nessus-config: nessus-config.pre Makefile nessus.tmpl
@echo Creating $@ ...
diff --git a/libhosts_gatherer/Makefile b/libhosts_gatherer/Makefile
index e2a647c..7d628d8 100644
--- a/libhosts_gatherer/Makefile
+++ b/libhosts_gatherer/Makefile
@@ -22,7 +22,7 @@ install : libhosts_gatherer.la
$(LIBTOOL) --finish $(DESTDIR)${libdir}
libhosts_gatherer.la : $(OBJS)
- $(LIBTOOL) $(CC) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
+ $(LIBTOOL) $(CC) $(LDFLAGS) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
-version-info ${PACKAGE_VERSION}
hg_utils.o : hg_utils.h hosts_gatherer.h hg_utils.c
diff --git a/libnessus/Makefile b/libnessus/Makefile
index c5a96db..211f57a 100644
--- a/libnessus/Makefile
+++ b/libnessus/Makefile
@@ -100,8 +100,8 @@ kb.o: kb.c
snprintf.o : snprintf.c
$(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c snprintf.c
libnessus.la: $(OBJS)
- $(LIBTOOL) $(CC) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
- -version-info ${PACKAGE_VERSION}
+ $(LIBTOOL) $(CC) $(LDFLAGS) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION} `pcap-config --libs` `pkg-config --libs openssl`
install : libnessus.la
test -d $(DESTDIR)${libdir} || $(INSTALL_DIR) -m 755 $(DESTDIR)${libdir}
diff --git a/libnessus/kb.c b/libnessus/kb.c
index 921c1a1..cbfd840 100644
--- a/libnessus/kb.c
+++ b/libnessus/kb.c
@@ -20,6 +20,7 @@
*/
#include <includes.h>
+#include <fnmatch.h>
#define HASH_MAX 65537