You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/cantor/files/cantor-15.12.3-tests.patch

50 lines
1.7 KiB

--- a/src/backends/maxima/CMakeLists.txt 2016-03-21 02:16:05.549024821 +0100
+++ b/src/backends/maxima/CMakeLists.txt 2016-03-21 02:22:07.951014021 +0100
@@ -21,12 +21,14 @@
target_link_libraries(cantor_maximabackend KF5::Pty)
endif(NOT WIN32)
+if (BUILD_TESTING)
add_executable( testmaxima testmaxima.cpp)
target_link_libraries( testmaxima
cantorlibs
cantortest
${QTTEST_LIBRARY}
)
+endif()
install( FILES cantor_maxima.knsrc DESTINATION ${KDE_INSTALL_CONFDIR} )
install( FILES keywords.xml cantor-initmaxima.lisp DESTINATION ${KDE_INSTALL_DATADIR}/cantor/maximabackend)
--- a/src/backends/sage/CMakeLists.txt 2016-03-21 01:23:19.251791138 +0100
+++ b/src/backends/sage/CMakeLists.txt 2016-03-21 01:27:16.300827617 +0100
@@ -17,12 +17,14 @@
target_link_libraries( cantor_sagebackend KF5::Pty)
+if (BUILD_TESTING)
add_executable( testsage testsage.cpp)
target_link_libraries( testsage
${QT_QTTEST_LIBRARY}
cantorlibs
cantortest
)
+endif()
install( FILES cantor_sage.knsrc DESTINATION ${KDE_INSTALL_CONFDIR} )
install( FILES keywords.xml DESTINATION ${KDE_INSTALL_DATADIR}/cantor/sagebackend)
--- a/src/backends/python2/CMakeLists.txt 2016-03-21 01:28:39.055793038 +0100
+++ b/src/backends/python2/CMakeLists.txt 2016-03-21 01:35:01.451012440 +0100
@@ -20,10 +20,12 @@
cantor_pythonbackend
)
+if (BUILD_TESTING)
add_executable(testpython2 testpython2.cpp)
target_link_libraries(testpython2 ${QT_QTTEST_LIBRARY} cantorlibs cantortest)
add_test(NAME testpython2 COMMAND testpython2)
+endif()
install(FILES cantor_python2.knsrc DESTINATION ${KDE_INSTALL_CONFDIR})
install(FILES python2backend.kcfg DESTINATION ${KDE_INSTALL_KCFGDIR})