You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix...

20 lines
622 B

commit b6df18997dabe37f4357d977d2dfae07899be5e7
Author: Michał Lipski <tallica@o2.pl>
Date: Mon May 7 12:48:23 2012 +0200
Use pkg-config for libsdl detection. (Gentoo #414999)
diff --git a/configure.ac b/configure.ac
index 358f841..cbba0ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -693,7 +693,7 @@ AC_ARG_ENABLE(sdlout,
[enable_sdlout=$enableval], [enable_sdlout=yes])
if test $enable_sdlout = yes ; then
- AM_PATH_SDL(1.2.5, [enable_sdlout=yes], [enable_sdlout=no])
+ PKG_CHECK_MODULES([SDL], [sdl >= 1.2.11], [enable_sdlout=yes], [enable_sdlout=no])
fi
if test $enable_sdlout = yes ; then