You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/vdr-wapd/files/vdr-wapd-0.9-as-needed.patch

17 lines
539 B

--- wapd-0.9.orig/Makefile 2008-01-16 16:29:10.000000000 +0100
+++ wapd-0.9/Makefile 2009-10-20 11:32:24.494591965 +0200
@@ -76,11 +76,11 @@
all: libvdr-$(PLUGIN).so wappasswd
libvdr-$(PLUGIN).so: $(OBJS)
- $(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -o $@
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@ $(LIBS)
@cp $@ $(LIBDIR)/$@.$(APIVERSION)
wappasswd: wappasswd.c
- $(CXX) $(CXXFLAGS) $(LIBS) -o wappasswd wappasswd.c
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o wappasswd wappasswd.c $(LIBS)
dist: clean
@-rm -rf $(TMPDIR)/$(ARCHIVE)