You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/slim/files/slim-1.3.6-fix-slimlock-nop...

27 lines
733 B

--- a/CMakeLists.txt 2013-10-27 21:24:21.193802669 -0400
+++ b/CMakeLists.txt 2013-10-27 21:26:54.127806951 -0400
@@ -220,7 +220,6 @@
####### install
# slim
install(TARGETS slim RUNTIME DESTINATION bin)
-install(TARGETS slimlock RUNTIME DESTINATION bin)
if (BUILD_SHARED_LIBS)
set_target_properties(libslim PROPERTIES
@@ -235,8 +234,14 @@
# man file
install(FILES slim.1 DESTINATION ${MANDIR}/man1/)
-install(FILES slimlock.1 DESTINATION ${MANDIR}/man1/)
# configure
install(FILES slim.conf DESTINATION ${SYSCONFDIR})
+
+#slimlock
+if(BUILD_SLIMLOCK)
+install(TARGETS slimlock RUNTIME DESTINATION bin)
+install(FILES slimlock.1 DESTINATION ${MANDIR}/man1/)
+endif(BUILD_SLIMLOCK)
+
# themes directory
subdirs(themes)