You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/xscreensaver/files/xscreensaver-5.20-tests-mis...

24 lines
784 B

http://pkgs.fedoraproject.org/cgit/xscreensaver.git/tree/xscreensaver-5.12-tests-miscfix.patch
--- driver/test-xdpms.c
+++ driver/test-xdpms.c
@@ -29,7 +29,6 @@
#include <X11/Xproto.h>
#include <X11/extensions/dpms.h>
-#include <X11/extensions/dpmsstr.h>
extern Bool DPMSQueryExtension (Display *dpy, int *event_ret, int *error_ret);
extern Bool DPMSCapable (Display *dpy);
--- driver/Makefile.in
+++ driver/Makefile.in
@@ -850,7 +850,7 @@
test-mlstring: test-mlstring.o
$(CC) -DTEST $(LDFLAGS) -o $@ test-mlstring.o $(SAVER_LIBS)
-TEST_FADE_OBJS = test-fade.o $(UTILS_SRC)/fade.o $(DEMO_UTIL_OBJS)
+TEST_FADE_OBJS = test-fade.o $(UTILS_BIN)/fade.o $(DEMO_UTIL_OBJS)
test-fade: test-fade.o $(UTILS_BIN)/fade.o
$(CC) $(LDFLAGS) -o $@ $(TEST_FADE_OBJS) $(SAVER_LIBS)