You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch

16 lines
393 B

Respect CFLAGS, don't strip binaries
http://bugs.gentoo.org/show_bug.cgi?id=252124
--- src/Makefile.am
+++ src/Makefile.am
@@ -10,5 +10,6 @@
modify.c modify.h \
misc.h define.h
-LIBS = @GTK_LIBS@
-AM_CFLAGS = -s -O2 -Wall @GTK_CFLAGS@ -DLOCALEDIR=\"$(datadir)/locale\"
+selectwm_LDADD = @GTK_LIBS@
+selectwm_CFLAGS = @GTK_CFLAGS@
+selectwm_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\"