You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-wm/xpra/files/xpra-0.16.2-prefix.patch

28 lines
941 B

--- xpra-0.16.2/setup.py
+++ xpra-0.16.2/setup.py
@@ -1723,8 +1723,8 @@
#prepare default [/usr/local]/etc configuration files:
if '--user' in sys.argv:
etc_prefix = 'etc/xpra'
- elif sys.prefix == '/usr':
- etc_prefix = '/etc/xpra'
+ elif sys.prefix[-4:] == '/usr':
+ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
else:
etc_prefix = sys.prefix + '/etc/xpra'
--- xpra-0.16.2/xpra/platform/paths.py
+++ xpra-0.16.2/xpra/platform/paths.py
@@ -40,9 +40,9 @@
def do_get_system_conf_dirs():
prefix = get_install_prefix()
#the system wide configuration directory
- if prefix == '/usr':
+ if prefix[-4:] == '/usr':
#default posix config location:
- return ['/etc/xpra']
+ return [sys.prefix[:-4] + '/etc/xpra']
#hope the prefix is something like "/usr/local" or "$HOME/.local":
return [prefix + '/etc/xpra/']