You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/bpftrace/files/bpftrace-0.10.0-dont-compre...

19 lines
722 B

diff --git a/man/man8/CMakeLists.txt b/man/man8/CMakeLists.txt
index f1fc334..7ee58ed 100644
--- a/man/man8/CMakeLists.txt
+++ b/man/man8/CMakeLists.txt
@@ -1,12 +1,3 @@
-find_program(GZIP gzip)
file(GLOB FILES *.8)
-set(GZFILES "")
-foreach(FIL ${FILES})
- get_filename_component(NAME ${FIL} NAME)
- add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${NAME}.gz
- COMMAND ${GZIP} -c ${FIL} > ${CMAKE_CURRENT_BINARY_DIR}/${NAME}.gz
- DEPENDS ${FIL})
- list(APPEND GZFILES "${CMAKE_CURRENT_BINARY_DIR}/${NAME}.gz")
-endforeach()
add_custom_target(man ALL DEPENDS ${GZFILES})
-install(FILES ${GZFILES} DESTINATION ${CMAKE_INSTALL_MANDIR}/man8)
+install(FILES ${FILES} DESTINATION ${CMAKE_INSTALL_MANDIR}/man8)