You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-misc/kio-gdrive/files/kio-gdrive-1.2.0-tests-opti...

22 lines
656 B

commit e9ddacb58dcf011bc2a877c11b026cab94031e65
Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
Date: Sat May 27 15:58:32 2017 +0200
If tests are optional, autotests subdir must be conditional
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c1b691..a2a771c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,7 +61,9 @@ add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
add_definitions(-DQT_STRICT_ITERATORS)
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_gdrive\")
-add_subdirectory(autotests)
+if(BUILD_TESTING)
+ add_subdirectory(autotests)
+endif()
add_subdirectory(desktop)
add_subdirectory(doc)
add_subdirectory(src)