You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-physics/root/files/root-6.11.02-hsimple.patch

35 lines
1.8 KiB

diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa05c02568..ef2b5e3f52 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -354,28 +354,6 @@ add_dependencies(onepcm ${__allTargets})
install(FILES ${CMAKE_BINARY_DIR}/etc/allDict.cxx.pch DESTINATION ${CMAKE_INSTALL_SYSCONFDIR})
install(DIRECTORY ${CMAKE_BINARY_DIR}/etc/dictpch DESTINATION ${CMAKE_INSTALL_SYSCONFDIR})
-#---hsimple.root---------(use the executable for clearer dependencies and proper return code)---
-if(NOT WIN32)
-add_custom_target(hsimple ALL DEPENDS tutorials/hsimple.root)
-add_dependencies(hsimple onepcm)
-if(WIN32)
- add_custom_command(OUTPUT tutorials/hsimple.root
- COMMAND set PATH=${CMAKE_RUNTIME_OUTPUT_DIRECTORY} &&
- set ROOTIGNOREPREFIX=1 &&
- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
- WORKING_DIRECTORY tutorials
- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
-else()
- add_custom_command(OUTPUT tutorials/hsimple.root
- COMMAND ${ld_library_path}=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}:$ENV{${ld_library_path}}
- ROOTIGNOREPREFIX=1
- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
- WORKING_DIRECTORY tutorials
- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
-endif()
-install(FILES ${CMAKE_BINARY_DIR}/tutorials/hsimple.root DESTINATION ${CMAKE_INSTALL_TUTDIR} COMPONENT tests)
-endif()
-
#---version--------------------------------------------------------------------------------------
if(NOT WIN32)
add_custom_target(version COMMAND ${CMAKE_SOURCE_DIR}/build/unix/makeversion.sh ${CMAKE_BINARY_DIR}