You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/wmxres/files/wmxres-1.2-r1-fix-build-sys...

24 lines
584 B

--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,15 @@
-INCDIR = -I/usr/X11R6/include
-LIBDIR = -L/usr/X11R6/lib
LIBS = -lXpm -lXext -lX11 -lXxf86vm
OBJS = wmxres/wmxres.o \
- wmgeneral/wmgeneral.o \
+ wmgeneral/wmgeneral.o
+CFLAGS += -Wall
.c.o:
- cc -g -c -O2 -Wall -D$(shell echo `uname -s`) $< -o $*.o $(INCDIR)
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -D$(shell echo `uname -s`) $< -o $@
all: wmxres
wmxres: $(OBJS)
- cc -o wmxres/wmxres $^ $(LIBDIR) $(LIBS)
+ $(CC) $(LDFLAGS) -o wmxres/wmxres $^ $(LIBS)
install:: all
install -s -m 4755 -o root wmxres/wmxres /usr/X11R6/bin