You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/hivex/files/1.3.5/0001-add_ocaml_triplet_in_c...

18 lines
641 B

diff --git a/configure.ac b/configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -187,10 +187,12 @@
AM_CONDITIONAL([HAVE_HIVEXSH],[test "x$ac_cv_func_open_memstream" = "xyes"])
dnl Check for OCaml (optional, for OCaml bindings).
+AC_ARG_ENABLE([ocaml],
+ AS_HELP_STRING([--with-ocaml],[build Ocaml binding]))
AC_PROG_OCAML
AC_PROG_FINDLIB
AM_CONDITIONAL([HAVE_OCAML],
- [test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno"])
+ [test "x$OCAMLC" != "xno" && test "x$OCAMLFIND" != "xno" -a "x$enable_ocaml" = "xyes"]])
AM_CONDITIONAL([HAVE_OCAMLOPT],
[test "x$OCAMLOPT" != "xno" && test "x$OCAMLFIND" != "xno"])