You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ml/fort/files/fort-0.4.2-ocaml4.patch

23 lines
648 B

Index: fort-0.4.2/Makefile
===================================================================
--- fort-0.4.2.orig/Makefile
+++ fort-0.4.2/Makefile
@@ -3,7 +3,7 @@
include Makefile.config
-OCAMLC := ocamlc
+OCAMLC := ocamlc -I +compiler-libs
# FORT top-level interpreter
NAME := fort
@@ -16,7 +16,7 @@ LIBS := unix
EXECUTABLE := $(NAME)$(EXEC_SUFFIX)
$(EXECUTABLE): $(OBJECTS)
- $(OCAMLC) -linkall -o $@ toplevellib.cma $(LIBS:%=%.cma) $(OBJECTS)
+ $(OCAMLC) -linkall -o $@ ocamlcommon.cma ocamlbytecomp.cma ocamltoplevel.cma $(LIBS:%=%.cma) $(OBJECTS)
install: $(EXECUTABLE) $(OBJECTS)
mkdir -p $(DESTDIR)$(LIBDIR)