You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-action/powermanga/files/powermanga-0.91-underlink.p...

22 lines
647 B

--- src/Makefile.am.old
+++ src/Makefile.am
@@ -8,7 +8,7 @@
powermanga_CFLAGS = -DPREFIX=\"$(prefix)\" \
-DSCOREFILE=\"$(scoredir)/$(score)\" \
@XLIB_CFLAGS@ @SDL_CFLAGS@
-powermanga_LDADD = @XLIB_LIBS@ @SDL_LIBS@
+powermanga_LDADD = @XLIB_LIBS@ @SDL_LIBS@ -lm
install-data-hook:
-chown root:games "$(DESTDIR)/$(gamesdir)/powermanga"
--- src/images.c
+++ src/images.c
@@ -31,6 +31,7 @@
#include "display.h"
#include "images.h"
#include "log_recorder.h"
+#include <zlib.h>
static char *bitmap_read (bitmap * bmp, Uint32 num_of_obj,
Uint32 num_of_images, char *addr,