You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/apng2gif/files/apng2gif-1.6-makefile.patch

18 lines
412 B

--- apng2gif-1.6-src/Makefile
+++ apng2gif-1.6-src/Makefile
@@ -1,11 +1,10 @@
PACKAGE = apng2gif
-CC = gcc
-CFLAGS = -Wall -pedantic
-CFLAGS_OPT = -O2
+CXX ?= g++
+CFLAGS += -Wall -pedantic
LIBS = -lstdc++ -lm -lpng -lz
all :
- $(CC) $(CFLAGS) $(CFLAGS_OPT) -o apng2gif apng2gif.cpp -s $(LIBS)
+ $(CXX) $(CFLAGS) $(LDFLAGS) -o apng2gif apng2gif.cpp $(LIBS)
.PHONY : clean