You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/flac/files/flac-1.3.0-dontbuild-exampl...

31 lines
723 B

--- flac-1.3.0/configure.ac
+++ flac-1.3.0/configure.ac
@@ -319,6 +319,12 @@
fi
AC_SUBST(OGG_PACKAGE)
+dnl Build examples?
+AC_ARG_ENABLE(examples,
+ AS_HELP_STRING([--disable-examples], [Don't build examples during make]),,
+ enable_examples="yes")
+AM_CONDITIONAL(EXAMPLES, [test "$enable_examples" = "yes"])
+
dnl check for i18n(internationalization); these are from libiconv/gettext
AM_ICONV
AM_LANGINFO_CODESET
--- flac-1.3.0/Makefile.am
+++ flac-1.3.0/Makefile.am
@@ -31,7 +31,11 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = doc include m4 man src examples test build objs
+SUBDIRS = doc include m4 man src test build objs
+
+if EXAMPLES
+SUBDIRS += examples
+endif
EXTRA_DIST = \
COPYING.FDL \