You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/hexinject/files/hexinject-1.5-fix-build-sys...

16 lines
433 B

Respect user flags
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
all:
- gcc -o hexinject hexinject.c -lpcap
- gcc -o prettypacket prettypacket.c
- gcc -o hex2raw hex2raw.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o hexinject hexinject.c -lpcap
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o prettypacket prettypacket.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o hex2raw hex2raw.c
clean:
rm -f hexinject prettypacket hex2raw *~