You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-dialup/diald/files/diald-1.0-gentoo.patch

51 lines
2.8 KiB

diff -Nru diald-1.0.orig/Makefile.in diald-1.0/Makefile.in
--- diald-1.0.orig/Makefile.in 2008-04-13 21:09:37.000000000 +0300
+++ diald-1.0/Makefile.in 2008-04-13 21:11:17.000000000 +0300
@@ -21,9 +21,13 @@
mandir = @mandir@
+ROOTUID = root
+ROOTGRP = root
+BINGRP = bin
+
CC = @CC@
CFLAGS = @CFLAGS@ @DEFS@ -I$(srcdir) \
- -DDIALD_CONFIG_FILE=\"@sysconfdir@/diald.conf\" \
+ -DDIALD_CONFIG_FILE=\"@sysconfdir@/diald/diald.conf\" \
-DDIALD_DEFS_FILE=\"@libdir@/diald/diald.defs\" \
-DRUN_PREFIX=\"@localstatedir@/run\"
INSTALL = @INSTALL@
@@ -51,21 +55,19 @@
$(INSTALL) -d $(DESTDIR)$(bindir)
$(INSTALL) -m 0755 bin/dctrl $(DESTDIR)$(bindir)/dctrl
$(INSTALL) -d $(DESTDIR)$(sbindir)
- $(INSTALL) -s -o root -g bin diald $(DESTDIR)$(sbindir)/diald
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) diald $(DESTDIR)$(sbindir)/diald
$(INSTALL) -d $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man5 \
$(DESTDIR)$(mandir)/man8
- $(INSTALL) -o root -g bin -m 0644 doc/diald.man $(DESTDIR)$(mandir)/man8/diald.8
- $(INSTALL) -o root -g bin -m 0644 doc/dctrl.man $(DESTDIR)$(mandir)/man1/dctrl.1
- $(INSTALL) -o root -g bin -m 0644 doc/diald-examples.man $(DESTDIR)$(mandir)/man5/diald-examples.5
- $(INSTALL) -o root -g bin -m 0644 doc/diald-control.man $(DESTDIR)$(mandir)/man5/diald-control.5
- $(INSTALL) -o root -g bin -m 0644 doc/diald-monitor.man $(DESTDIR)$(mandir)/man5/diald-monitor.5
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 doc/diald.man $(DESTDIR)$(mandir)/man8/diald.8
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 doc/dctrl.man $(DESTDIR)$(mandir)/man1/dctrl.1
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 doc/diald-examples.man $(DESTDIR)$(mandir)/man5/diald-examples.5
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 doc/diald-control.man $(DESTDIR)$(mandir)/man5/diald-control.5
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 doc/diald-monitor.man $(DESTDIR)$(mandir)/man5/diald-monitor.5
-mkdir -p $(DESTDIR)$(libdir)
- $(INSTALL) -o root -g bin lib/*.gif $(DESTDIR)$(libdir)
- $(INSTALL) -o root -g bin -m 0644 config/diald.defs $(DESTDIR)$(libdir)/diald.defs
- $(INSTALL) -o root -g bin -m 0644 config/standard.filter $(DESTDIR)$(libdir)/standard.filter
- $(INSTALL) -d -m 0755 $(DESTDIR)/etc/pam.d
- $(INSTALL) -o root -g root -m 0644 config/diald.pam $(DESTDIR)/$(sysconfdir)/pam.d/diald
- $(INSTALL) -o root -g bin bin/connect $(DESTDIR)$(libdir)/connect
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) lib/*.gif $(DESTDIR)$(libdir)
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 config/diald.defs $(DESTDIR)$(libdir)/diald.defs
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 config/standard.filter $(DESTDIR)$(libdir)/standard.filter
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) bin/connect $(DESTDIR)$(libdir)/connect
clean:
rm -f *.o diald