You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-dns/idnkit/files/idnkit-1.0-autotools.patch

65 lines
1.8 KiB

--- a/configure.in 2003-03-11 00:53:20.000000000 +0100
+++ b/configure.in 2010-03-12 14:15:24.000000000 +0100
@@ -629,6 +629,41 @@
fi
fi
+AC_DEFUN(AC_FIND_SYSTEM_SHOBJ,[
+AC_MSG_CHECKING(for $1 shared object)
+shobj_name=$1
+shobj_path=
+case "$host" in
+*-hpux*)
+ SOEXT=sl
+ ;;
+*)
+ SOEXT=so
+ ;;
+esac
+for shobj_libdir in /lib /usr/lib; do
+ if test -f $shobj_libdir/$shobj_name.$SOEXT; then
+ shobj_path=$shobj_libdir/$shobj_name.$SOEXT
+ else
+ shobj_path=`ls -r $shobj_libdir/$shobj_name.$SOEXT* 2>/dev/null | head -1`
+ if test "$shobj_path" != "" -a -f "$shobj_path"; then
+ :
+ else
+ shobj_path=
+ fi
+ fi
+ if test "$shobj_path" != ""; then
+ AC_MSG_RESULT($shobj_path)
+ shobj_pathsymbol=SOPATH_`echo $shobj_name | sed 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
+ AC_DEFINE_UNQUOTED($shobj_pathsymbol, "$shobj_path")
+ break
+ fi
+done
+if test "$shobj_path" = ""; then
+ AC_MSG_RESULT(no)
+fi
+])dnl
+
dnl Find system shared object paths.
AC_FIND_SYSTEM_SHOBJ(libc)
if test "$install_runidn" = yes ; then
--- a/lib/Makefile.in 2003-03-12 17:14:41.000000000 +0100
+++ b/lib/Makefile.in 2010-03-12 15:54:35.000000000 +0100
@@ -241,7 +241,7 @@
install-common:
$(MKINSTALLDIRS) $(DESTDIR)$(libdir)
- $(LIBTOOL) $(INSTALL_DATA) $(LITELIB).la \
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(LITELIB).la \
$(DESTDIR)$(libdir)/$(LITELIB).la
-[ -f $(DESTDIR)$(libdir)/$(LITELIB).a ] \
&& $(RANLIB) $(DESTDIR)$(libdir)/$(LITELIB).a
@@ -262,7 +262,7 @@
install-nolite:
$(MKINSTALLDIRS) $(DESTDIR)$(libdir)
- $(LIBTOOL) $(INSTALL_DATA) $(LIB).la \
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(LIB).la \
$(DESTDIR)$(libdir)/$(LIB).la
-[ -f $(DESTDIR)$(libdir)/$(LIB).a ] \
&& $(RANLIB) $(DESTDIR)$(libdir)/$(LIB).a