You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-irc/bnc/files/bnc-2.9.4-build.patch

34 lines
791 B

--- Makefile.in
+++ Makefile.in
@@ -1,8 +1,17 @@
LIBS=@LIBS@
-CFLAGS=-O3 -Wall -include config.h
+CFLAGS=@CFLAGS@ -Wall -include config.h
CC=@CC@
+
+DESTDIR =
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+bindir = @bindir@
-ALL: bnc mkpasswd
+all ALL: bnc mkpasswd
+
+install: bnc mkpasswd
+ install -m 755 -d $(DESTDIR)$(bindir)
+ install -m 755 bnc mkpasswd bncchk bncsetup $(DESTDIR)$(bindir)
mkpasswd:mkpasswd.c
${CC} ${CFLAGS} -o mkpasswd mkpasswd.c ${LIBS}
--- configure.in
+++ configure.in
@@ -35,7 +35,7 @@
dnl Check for SSL support.
AC_MSG_CHECKING(whether to enable SSL support)
AC_ARG_WITH(ssl,
-[ -with-ssl Enable SSL support],
+[ --with-ssl Enable SSL support],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)