You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libpdb/files/991112-dynlib.patch

13 lines
342 B

diff --git a/Makefile b/Makefile
index 760a427..da2f62d 100644
--- a/Makefile
+++ b/Makefile
@@ -29,6 +29,7 @@ install: $(LIBARCH)
$(LIBARCH): $(OBJS)
@echo "Loading $(LIBARCH) ... "
+ $(CC) $(LDFLAGS) -shared -Wl,--soname,libpdb.so.0 -o libpdb.so.0.1 $(OBJS)
@ar cru $(LIBARCH) $(OBJS)
@$(RANLIB) $(LIBARCH)
@echo "done"