You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lua/luasystem/files/luasystem-0.2.1_p0-fix-make...

34 lines
825 B

diff --git a/src/Makefile b/src/Makefile
index 10fc31a..af5e4e4 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -144,8 +144,8 @@ O_linux=o
CC_linux=gcc
DEF_linux=
CFLAGS_linux= -I$(LUAINC) $(DEF) -Wall -Wshadow -Wextra \
- -Wimplicit -O2 -ggdb3 -fpic -fvisibility=hidden
-LDFLAGS_linux=-lrt -O -shared -fpic -o
+ -Wimplicit -fpic -fvisibility=hidden
+LDFLAGS_linux=-lrt -shared -fpic -o
LD_linux=gcc
#------
@@ -208,7 +208,7 @@ SOLIB=core.$(SO)
#
CC=$(CC_$(PLAT))
DEF=$(DEF_$(PLAT))
-CFLAGS=$(MYCFLAGS) $(CFLAGS_$(PLAT))
+CFLAGS=$(CFLAGS_$(PLAT)) $(MYCFLAGS)
LDFLAGS=$(MYLDFLAGS) $(LDFLAGS_$(PLAT))
LD=$(LD_$(PLAT))
LUAINC= $(LUAINC_$(PLAT))
@@ -248,7 +248,7 @@ none:
all: $(SOLIB)
$(SOLIB): $(OBJS)
- $(LD) $(OBJS) $(LDFLAGS)$@
+ $(LD) $(OBJS) $(LDFLAGS) $@
install: all
$(INSTALL_DIR) $(INSTALL_TOP_LDIR)