You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/pstotext/files/1.9-flags.patch

37 lines
775 B

diff --git a/Makefile b/Makefile
index 551e3b8..1d55ebe 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@
# commenting out the includes of ptotdll.h in ptotdll.c and main.c.
# PMcJ 6 Sep 96
-CC=gcc
+CC ?= gcc
#CC=cc -std
BUNDLE = ocr.h rot270.h rot90.h
@@ -17,18 +17,18 @@ BUNDLE = ocr.h rot270.h rot90.h
all: pstotext
main.o: main.c ptotdll.h bundle.h ocr.h rot270.h rot90.h
- $(CC) -c $*.c
+ $(CC) $(CFLAGS) -c $*.c
ptotdll.o: ptotdll.c ptotdll.h
- $(CC) -c $*.c
+ $(CC) $(CFLAGS) -c $*.c
pstotext: bundle.o main.o ptotdll.o
- $(CC) -o pstotext main.o bundle.o ptotdll.o -lm
+ $(CC) $(CFLAGS) $(LDFLAGS) -o pstotext main.o bundle.o ptotdll.o -lm
.SUFFIXES: .ps
.c.o:
- $(CC) -c $*.c
+ $(CC) $(CFLAGS) -c $*.c
# "Bundle" an Ascii file.
.ps.h: