You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ros/cv_bridge/files/ocv_leak.patch

21 lines
536 B

Index: cv_bridge/CMakeLists.txt
===================================================================
--- cv_bridge.orig/CMakeLists.txt
+++ cv_bridge/CMakeLists.txt
@@ -17,14 +17,7 @@ else()
find_package(Boost REQUIRED)
endif()
-set(_opencv_version 4)
-find_package(OpenCV 4 QUIET)
-if(NOT OpenCV_FOUND)
- message(STATUS "Did not find OpenCV 4, trying OpenCV 3")
- set(_opencv_version 3)
-endif()
-
-find_package(OpenCV ${_opencv_version4} REQUIRED
+find_package(OpenCV 4 REQUIRED
COMPONENTS
opencv_core
opencv_imgproc