You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-scheme/scm/files/scm-5.5.6-respect-ldflags.p...

12 lines
395 B

diff -ur b/Makefile a/Makefile
--- b/Makefile 2018-06-21 14:02:53.439716620 -0500
+++ a/Makefile 2018-06-21 14:03:33.900568504 -0500
@@ -111,7 +111,7 @@
# SCMLIT -- try making this first!
scmlit: $(ofiles) scmmain.o require.scm Makefile
- $(LD) -o scmlit $(ofiles) scmmain.o $(LIBS)
+ $(LD) $(LDFLAGS) -o scmlit $(ofiles) scmmain.o $(LIBS)
$(MAKE) checklit
scmflags.h: scmflags
scmflags: