You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/supercollider/files/supercollider-3.10.2-no-cca...

26 lines
927 B

disabled the use of ccache, to prevent FTBFS; as the compilation is done once
it has no backdraws to make the debian package.
Index: supercollider/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,12 +150,12 @@ add_definitions(-DBOOST_CHRONO_HEADER_ON
#############################################
# Detect CCache
-find_program(CCacheExectuable ccache)
-if( CCacheExectuable )
- # only used with >=cmake-3.4
- set( CMAKE_C_COMPILER_LAUNCHER "${CCacheExectuable}" )
- set( CMAKE_CXX_COMPILER_LAUNCHER "${CCacheExectuable}" )
-endif()
+## find_program(CCacheExecutable ccache)
+## if( CCacheExecutable )
+## # only used with >=cmake-3.4
+## set( CMAKE_C_COMPILER_LAUNCHER "${CCacheExecutable}" )
+## set( CMAKE_CXX_COMPILER_LAUNCHER "${CCacheExecutable}" )
+## endif()
#############################################
# Options