You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-proxy/squirm/files/squirm-1.26-gentoo.patch

34 lines
865 B

--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
# $Id$
# The path to install squirm under
-PREFIX=/usr/local/squirm
+PREFIX=/opt/squirm
# The username that squid runs as (see cache_effective_user in squid.conf)
USER=squid
@@ -29,10 +29,10 @@
CC=gcc
-OPTIMISATION=-O3
+OPTIMISATION=
BINARIES = squirm
-CFLAGS = -O3 -Wall -funroll-loops -DPREFIX=\"$(PREFIX)\"
+CFLAGS += -DPREFIX=\"$(PREFIX)\"
#CFLAGS = -Wall -g -DPREFIX=\"$(PREFIX)\"
#CFLAGS = -Wall -g -DDEBUG
@@ -45,7 +45,7 @@
install -m 750 -o $(USER) -g $(GROUP) -d $(PREFIX)/logs
install -m 660 -c -o root -g $(GROUP) squirm.conf.dist squirm.patterns.dist \
$(PREFIX)/etc
- install -m 755 -o root -g $(ROOT_GROUP) --strip squirm $(PREFIX)/bin
+ install -m 755 -o root -g $(ROOT_GROUP) squirm $(PREFIX)/bin
squirm.o: squirm.c $(HFILES)
$(CC) -c squirm.c $(CFLAGS)