You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/nut/files/nut-14.1-build-fixes.patch

15 lines
400 B

* Use $(CC) instead of gcc.
* Honor LDFLAGS.
* Put -l flags at the end so it doesn't break --as-needed linker flag (bug #246904)
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
CFLAGS= -O3 -s -Wall -DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/local/lib/nut\" -ansi -pedantic
nut: $(objects)
- gcc ${CFLAGS} -lm -o nut $(objects)
+ $(CC) ${CFLAGS} -o nut $(LDFLAGS) $(objects) -lm
deps:
makedepend *.c