You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/jemalloc/files/jemalloc-5.3.0-gentoo-fixup...

44 lines
1.2 KiB

This is jemalloc-5.2.0-gentoo-fixups.patch, rebased on top of upstream commit
https://github.com/jemalloc/jemalloc/commit/ed5fc14b28ca62a6.
From: Jory Pratt <anarchy@gentoo.org>
Date: Tue, 23 Apr 2019 10:04:19 -0500
Subject: [PATCH] Don't override user cflags, disable html_doc from being
installed
Signed-off-by: Jory Pratt <anarchy@gentoo.org>
--- a/Makefile.in
+++ b/Makefile.in
@@ -603,7 +603,7 @@ install_doc_man: build_doc_man
$(INSTALL) -v -m 644 $$d $(MANDIR)/man3; \
done
-install_doc: install_doc_html install_doc_man
+install_doc: install_doc_man
install: install_bin install_include install_lib
--- a/configure.ac
+++ b/configure.ac
@@ -1220,21 +1220,6 @@ if test "x$enable_debug" = "x1" ; then
fi
AC_SUBST([enable_debug])
-dnl Only optimize if not debugging.
-if test "x$enable_debug" = "x0" ; then
- if test "x$GCC" = "xyes" ; then
- JE_CFLAGS_ADD([-O3])
- JE_CXXFLAGS_ADD([-O3])
- JE_CFLAGS_ADD([-funroll-loops])
- elif test "x$je_cv_msvc" = "xyes" ; then
- JE_CFLAGS_ADD([-O2])
- JE_CXXFLAGS_ADD([-O2])
- else
- JE_CFLAGS_ADD([-O])
- JE_CXXFLAGS_ADD([-O])
- fi
-fi
-
dnl Enable statistics calculation by default.
AC_ARG_ENABLE([stats],
[AS_HELP_STRING([--disable-stats],