You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-cpp/tree/files/tree-2.81-test.patch

37 lines
550 B

--- a/Makefile
+++ b/Makefile
@@ -1,13 +1,6 @@
-
-%.o: %.cc
- g++ -c -I. $^
-
-test1: test1.o
- g++ -o test1 test1.o
-
-run_tests: test1 test1.req
- ./test1 > test1.res
- @diff test1.res test1.req
+check: test_tree
+ ./test_tree > mytest.output && \
+ diff -Nu test_tree.output mytest.output
@echo "*** All tests OK ***"
clean:
--- a/test_tree.output
+++ b/test_tree.output
@@ -1,3 +1,8 @@
+-----
+hi
+ 1
+ 0
+-----
empty tree to begin with:
0
'more text' is sibling 2 in its sibling range
@@ -309,3 +314,5 @@
D
I
-----
+G
+H