You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-roguelike/nethack/files/3.4.3-X-support.patch

27 lines
920 B

--- include/config.h.orig 2003-06-21 20:58:57.000000000 -0400
+++ include/config.h 2003-06-21 20:59:44.000000000 -0400
@@ -46 +46 @@
-/* #define X11_GRAPHICS */ /* X11 interface */
+#define X11_GRAPHICS 1
@@ -127 +127 @@
-/* # define USE_XPM */ /* Disable if you do not have the XPM library */
+# define USE_XPM 1
--- Makefile.orig 2003-06-21 21:01:03.000000000 -0400
+++ Makefile 2003-06-21 21:01:16.000000000 -0400
@@ -43 +43 @@
-VARDATND =
+VARDATND = x11tiles pet_mark.xbm rip.xpm
--- src/Makefile.orig 2003-06-21 21:02:01.000000000 -0400
+++ src/Makefile 2003-06-21 21:02:11.000000000 -0400
@@ -207,2 +207,2 @@
-WINSRC = $(WINTTYSRC)
-WINOBJ = $(WINTTYOBJ)
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
@@ -228 +228 @@
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
+WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
@@ -248 +248 @@
-WINLIB = $(WINTTYLIB)
+WINLIB = $(WINTTYLIB) $(WINX11LIB)