You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libprelude/files/libprelude-3.0.0-ruby-confi...

15 lines
619 B

--- a/configure.in
+++ b/configure.in
@@ -525,9 +525,9 @@
dnl * Ruby support *
dnl **************************************************
-
-AM_PATH_RUBY(,with_ruby=yes, with_ruby=no)
+AC_ARG_WITH(ruby, AC_HELP_STRING(--with-ruby@<:@=PATH@:>@, Enable support for ruby binding @<:@default=auto@:>@),,with_ruby=no)
if test x$with_ruby != xno; then
+ AM_PATH_RUBY(,with_ruby=yes, with_ruby=no)
RUBY_ARCHDIR=`$RUBY -e 'require "rbconfig.rb"; puts RbConfig::expand("\$(archdir)")'`
RUBY_LIBRUBYARG=`$RUBY -e 'require "rbconfig.rb"; puts RbConfig::expand("\$(LIBRUBYARG)")'`