You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/u2ps/files/u2ps-1.2-respect-ldflags.patch

14 lines
337 B

diff --git a/Makefile b/Makefile
index 8a526f0..88b90b3 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ u2ps: u2ps.o u2ps_opts.o u2ps_data.o u2ps_file.o u2ps_page.o u2ps_pswr.o \
ttf2pt42: ttf2pt42.o warn.o
%: %.o
- $(CC) -o $@ $(filter %.o,$^)
+ $(CC) -o $@ $(filter %.o,$^) ${LDFLAGS}
.c.o:
$(CC) $(CFLAGS) -o $@ -c $<