You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-make...

20 lines
693 B

# https://bugs.gentoo.org/726014
# https://bugs.gentoo.org/781125
--- a/modules/60crypt-ssh/helper/Makefile
+++ b/modules/60crypt-ssh/helper/Makefile
@@ -17,11 +17,11 @@ clean:
rm -f *.o console_auth unlock crypttab-test
console_auth: auth.c
- $(CC) $(CFLAGS) $^ -o $@
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -o $@
unlock: crypttab.o unlock.o
- $(CC) $(CFLAGS) -lblkid $^ -o $@
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -lblkid -o $@
crypttab-test: crypttab-test.c crypttab.o crypttab-test-data
- $(CC) crypttab-test.c $(CFLAGS) crypttab.o -lblkid -o crypttab-test
+ $(CC) crypttab-test.c $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) crypttab.o -lblkid -o crypttab-test
./crypttab-test