You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/elixir/files/elixir-1.10.3-epmd-daemon.p...

14 lines
512 B

Avoid exec/SIGCHLD race in daemon fork.
Let's see if it fixes race seen in https://bugs.gentoo.org/727344
--- a/Makefile
+++ b/Makefile
@@ -280,7 +280,7 @@ test_elixir: test_stdlib test_ex_unit test_logger test_mix test_eex test_iex
test_stdlib: compile
@ echo "==> elixir (ex_unit)"
- $(Q) exec epmd & exit
+ $(Q) epmd -daemon
$(Q) if [ "$(OS)" = "Windows_NT" ]; then \
cd lib/elixir && cmd //C call ../../bin/elixir.bat -r "test/elixir/test_helper.exs" -pr "test/elixir/**/$(TEST_FILES)"; \
else \